MySQL #2002 Fejl

Har du problemer med din server eller kan du ikke bestemme dig for en hosting udbyder? - Så stil dine spørgsmål her! :)
Besvar
Nicolajsen
Begynder
Indlæg: 14
Tilmeldt: 24. jan 2012, 21:25

MySQL #2002 Fejl

Indlæg af Nicolajsen » 26. jan 2012, 21:08

Hej !

Jeg er endelig kommet lidt igang med min hjemmeside med stor hjælp fra Daniel.
Dog har vi et problem med MySQL, som jeg vil høre om der er nogen af jer der kan hjælpe med.

Jeg prøvede først og fremmest den nyeste version af xampp, hvor jeg ikke kunne få adgang til noget som helst.
Kunne ikke ændre kodeord og status deactivated.

Dernæst, efter inspiration fra en tidligere tråd her på siden, har jeg prøvet og installere en ældre udgave af xampp.
Det virker bedre og har ladet mig ændre kodeord og status siger at MySQL er Activated.
Men hvis jeg prøver at trykke phpmyadmin får jeg følgende fejl:

Fejl
MySQL returnerede:
#2002 - Serveren svarer ikke (eller den lokale MySQL servers socket er ikke korrekt konfigureret)

Jeg får samme fejl i wampp.

Jeg kører Win 7 64 bit, og jeg har prøvet følgende:
- "deaktivere" UAC (så meget som win 7 tillader)
- deaktivere windows firewall + firewall i min antivirus.
- kører alle programmer som administrator

Nogen der kan hjælpe mig videre ??

Brugeravatar
ThomasI
Grundlægger
Grundlægger
Indlæg: 1528
Tilmeldt: 28. dec 2010, 10:49

Re: MySQL #2002 Fejl

Indlæg af ThomasI » 26. jan 2012, 21:24

Hmm...

Jeg fandt det her på et engelsk forum:

http://www.apachefriends.org/f/viewtopi ... 16&t=49517

Måske kan det hjælpe dig...

Nicolajsen
Begynder
Indlæg: 14
Tilmeldt: 24. jan 2012, 21:25

Re: MySQL #2002 Fejl

Indlæg af Nicolajsen » 26. jan 2012, 21:56

Hej Thomas

Jeg har været inde i \xampp\mysql\bin\my.ini file
Som de skriver i linket du sender, og de skriver man # foran bind-address="127.0.0.1"

Men jeg har ikke en linie i min ini fil der hedder #bind-address="127.0.0.1"

??

Brugeravatar
ThomasI
Grundlægger
Grundlægger
Indlæg: 1528
Tilmeldt: 28. dec 2010, 10:49

Re: MySQL #2002 Fejl

Indlæg af ThomasI » 27. jan 2012, 09:33

Må indrømme at jeg ret meget på bar bundt...

Lyder til at det er et udbredt problem og at nogen får det løst ret let mens andre skal ind og rode i deres terminal med alt muligt...

Jeg fandt endnu et link:

http://forums.techguy.org/web-design-de ... r-not.html

Tror desværre det er det bedste jeg kan hjælpe dig, da jeg aldrig selv at oplevet problemet og derved fundet en løsning...

Hvis du finder en løsning på du meget gerne skrive den her...

Nicolajsen
Begynder
Indlæg: 14
Tilmeldt: 24. jan 2012, 21:25

Re: MySQL #2002 Fejl

Indlæg af Nicolajsen » 28. jan 2012, 16:05

ThomasI skrev:Må indrømme at jeg ret meget på bar bundt...

Lyder til at det er et udbredt problem og at nogen får det løst ret let mens andre skal ind og rode i deres terminal med alt muligt...

Jeg fandt endnu et link:

http://forums.techguy.org/web-design-de ... r-not.html

Tror desværre det er det bedste jeg kan hjælpe dig, da jeg aldrig selv at oplevet problemet og derved fundet en løsning...

Hvis du finder en løsning på du meget gerne skrive den her...
Hej Thomas !

Så fandt jeg en løsning !!
Det var lige præcis det link du sendte der fik det til og virke.

Jeg gik ind i /xampp/mysql/bin/my.ini og rettede
socket = "MySQL" til "/tmp/mysql.sock"

Og så gjorde jeg det samme i /xampp/php/php.ini
(søg på "socket" så finder man hurtigt en linie hvor der også står "MySQL")
Ret det til "/tmp/mysql.sock" begge steder, og så kører det !!

Håber det kan hjælpe andre med samme problem :-)

Besvar