PHP fejlmelding (?)

Her kan du få hjælp og stille spørgsmål til PHP!
Besvar
kme
Begynder
Indlæg: 1
Tilmeldt: 6. dec 2013, 11:33

PHP fejlmelding (?)

Indlæg af kme » 6. dec 2013, 11:38

Hej

Jeg er MEGET ny i PHP programmering.

Jeg er ved at lave et projekt hvor en microcontroler uploader nogle måleværdier til en database. Databasen ligger hos one.com (MySQL)

Jeg får denne fejl meddelse når koden afvikles:

Connected successfully
SensorType:
Value:
SensorId:
Time:1386326243
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''Measure_data' ('Hus_Id','sensor_id' ,'Time_stamp_Device', 'Value') VALUES (,,,)' at line 1done // http://www.intelihus.dk/log2.php?Sensor ... t&value=20

Koden er relativ simple ser sådan ud:

<?php
$link = mysql_connect('XXXXXXX.dk.mysql', 'XXXXXX_dk', 'mentz');
if (!$link) {
die('Could not connect: ' . mysql_error());
}
echo 'Connected successfully';

mysql_select_db('intelihus_dk', $link);

$value = htmlspecialchars($_GET["value"]);
$hus = htmlspecialchars($_GET["hus"]);
$sensor = htmlspecialchars($_GET["sensor"]);
$time = htmlspecialchars($_GET["time"]);

echo "<BR>SensorType: ".htmlspecialchars($_GET["SensorType"])."<BR>";
echo "Value: ".htmlspecialchars($_GET["Val"])."<BR>";
echo "SensorId: ".htmlspecialchars($_GET["SensorId"])."<BR>";
echo "Time:".time()."<BR>";


//echo "value: " $value;
//echo "sensor: " $sensor;
//echo "hus: " $hus;

$sql = "INSERT INTO 'Measure_data' (Hus_Id, Time_stamp_Device, Value) VALUES (1, 2, 45);";
$sql = "INSERT INTO 'Measure_data' ('ID', 'Hus_Id', 'Time_stamp_Device', 'Value') VALUES (1,2,3,4);";
$sql = "INSERT INTO 'Measure_data' ('Hus_Id','sensor_id' ,'Time_stamp_Device', 'Value') VALUES ($hus,$sensor,$time,$value);";
mysql_query($sql);

echo mysql_error();
echo 'done';

mysql_close($link);
?>

På forhånd tak for hjælpen

/Karsten

Brugeravatar
scootergrisen
Moderator
Moderator
Indlæg: 709
Tilmeldt: 21. jun 2012, 23:40
Kontakt:

Re: PHP fejlmelding (?)

Indlæg af scootergrisen » 6. dec 2013, 17:14

Dine variabler $hus,$sensor,$time,$value er muligvis ikke sat til nogen værdi.

Slå fejlbeskeder til øverst i din kode.

Kode: Vælg alt

<?php

ini_set("display_startup_errors", "on");
ini_set("display_errors", "on");
ini_set("html_errors", "false"); // slip for HTML koder i fejlbeskeder
error_reporting(-1); // -1 viser alle slags fejl beskeder

?>
Ikke at det besvare dit spørgsmål men den kode du bruger er deprecated i PHP 5.5.0 så bedre og bruge MySQLi eller PDO_MySQL.
http://www.php.net/manual/en/function.mysql-connect.php

Besvar