ÆØÅ - problem

Her kan du stille og svare på spørgsmål omkring HTML. Du kan altså med andre ord finde en masse hjælp til HTML og HTML5 på dette forum
Besvar
Freddy
Begynder
Indlæg: 15
Tilmeldt: 25. apr 2014, 01:58

ÆØÅ - problem

Indlæg af Freddy » 6. maj 2014, 14:19

Hej

Jeg har lavet en fil i phpMy*Admin over mine LP'er. Jeg har så lavet et lille php program der viser disse data i en tabel . Men det giver problemer med æøå

Hvis jeg bruger <meta charset="UTF-8"> bliver overskriften korrekt, men i selve tabellen bliver æ ø å til mærkelige tegn:

Linje nr. KunstnerLP LP titel År Plademærke
127 En pr�ve p� ��� � � � � � � 0
126 Radiounderholdningsorkestret En s�ndag p� Amager 1963 SLUPM 7013
125 Julie Andrews,Chr. Plummer The Sound of Music 1965 LSOD 2005

Hvis jeg bruger <meta charset="ISO-8859-1"> bliver selve tabellen korrekt, men så er det overskriften der bliver mærkelig:

Linje nr. Kunstner LP titel År Plademærke

127 En prøve på æøå æ ø å Æ Ø Å 0
126 Radiounderholdningsorkestret En søndag på Amager 1963 SLUPM 7013
125 Julie Andrews,Chr. Plummer The Sound of Music 1965 LSOD 2005

Er det ikke underligt, at tabellen og overskriften bliver forskellig?
Er der en helt tredje charset jeg skal bruge?
Jeg er godt klar over at jeg kan bruge (og det virker)
&aelig; = æ
&Aelig; = Æ
&oslash; = ø
&Oslash; = Ø
&aring; = å
&Aring; = Å
men det er vel ikke den korrekte måde?

Starten af koden ser sådan ud:

<html lang="da">
<head>
<meta charset="ISO-8859-1">
<title>LP oversigt</title>
<link rel="stylesheet" href="CSSfil.css" type="text/css"/>
</head>
<body>
Er noget galt med den?
Håber der er én der kan give mig et par stikord, for jeg kan ikke lige se hvad der er galt.
<?php

Brugeravatar
ThomasI
Grundlægger
Grundlægger
Indlæg: 1528
Tilmeldt: 28. dec 2010, 10:49

Re: ÆØÅ - problem

Indlæg af ThomasI » 6. maj 2014, 14:52

Hej med dig,

Prøv ar se nogle af vores tidligere tråde om dette problem:

http://www.nemprogrammering.dk/forum/vi ... f=35&t=965

http://www.nemprogrammering.dk/forum/vi ... ?f=3&t=618

Brugeravatar
Daniel
Admin
Admin
Indlæg: 625
Tilmeldt: 14. jun 2011, 09:27
Geografisk sted: Danmark, Fyn, Nørre Aaby
Kontakt:

Re: ÆØÅ - problem

Indlæg af Daniel » 6. maj 2014, 14:53

Hej Freddy.

Når du bruger UTF-8, så virker specialtegn i din overskrift, fordi dit dokument er gemt med UTF-8 encoding.
Men ligesom at man skal huske at sætte sit charset i HTML, så skal man også sætte det samme charset med MySQL.

Kode: Vælg alt

<?php
$mysql = mysql_connect($vært, $brugernavn, $kodeord);
mysql_select_db($database, $mysql);
mysql_set_charset('utf8');
Ved at bruge mysql_set_charset funktionen, vælger du hvilket charset der bliver brugt til at trække data ud fra databasen med.

Brugeravatar
scootergrisen
Moderator
Moderator
Indlæg: 709
Tilmeldt: 21. jun 2012, 23:40
Kontakt:

Re: ÆØÅ - problem

Indlæg af scootergrisen » 6. maj 2014, 17:26

Hvis de ting ikke hjælper så prøv og kig på det der hedder Collation med phpmyadmin.

Der er både "Server connection collation" og collation for hver table... ikke at jeg ved så meget om det.

Men hvis de er sat til latin1 kunne det måske være derfor.

Freddy
Begynder
Indlæg: 15
Tilmeldt: 25. apr 2014, 01:58

Re: ÆØÅ - problem

Indlæg af Freddy » 7. maj 2014, 17:14

Hej Daniel, Thomas og Scotergrisen

Tak for jeres input. Jeg har prøvet de forskellige forslag også dem fra tidligere tråde. herunder at ændre i php.ini, men der var ikke noget der gav resultat.
MEN, Scotergrisen skrev noget om Latin1 og det fik mig til at tænke på tabellen jeg kreerede i phpMyAdmin.
Jeg lavede så en ny tabel med utf8_danish_ci og det samme med de enkelte kolonner - BINGO - så virkede det. Så tusind tak for tippet Scotergrisen, men også til Daniel og Thomas, fordi i alle ville bruge tid på at hjælpe en dum nybegynder.

MrLundholm
Rutineret
Rutineret
Indlæg: 50
Tilmeldt: 20. sep 2013, 15:33
Kontakt:

Re: ÆØÅ - problem

Indlæg af MrLundholm » 7. maj 2014, 20:31

Lige en note til Danielh007, så er mysql ikke længere understøttet i PHP 5.5.0 og fremover. Lær i derfor om mysqli eller pdo :)

Brugeravatar
Daniel
Admin
Admin
Indlæg: 625
Tilmeldt: 14. jun 2011, 09:27
Geografisk sted: Danmark, Fyn, Nørre Aaby
Kontakt:

Re: ÆØÅ - problem

Indlæg af Daniel » 7. maj 2014, 21:22

MrLundholm skrev:Lige en note til Danielh007, så er mysql ikke længere understøttet i PHP 5.5.0 og fremover. Lær i derfor om mysqli eller pdo :)
Jeg benytter skam selv MySQLi og PDO i hverdagen, MySQLi ved gode gammeldags PHP projekter og PDO i OOP projekter. ;)

Og super at du fandt en løsning, det burde ikke være nødvendigt at ændre i din databases tegnsæt, men så længe det virker, så er alt fint. :)

Besvar